Tin An Ninh Mạng

Lỗi nghiêm trọng ảnh hưởng đến 70 nghìn trang WordPress

Lỗ hổng thực thi mã từ xa không được xác thực CVE-2023-4634 ảnh hưởng đến plugin Media-Library-Assistant – một công cụ có hơn 70.000 lượt cài đặt trên toàn thế giới.


{

}

wp-featured.jpeg

Lỗ hổng xảy ra do việc thiếu sự kiểm soát đối với đường dẫn tệp được cung cấp tham số ‘mla_stream_file’ từ tệp ~/includes/mla-stream-image.php, trong đó hình ảnh được xử lý thông qua Imagick(). Điều này giúp những kẻ tấn công không được xác thực có thể cung cấp các tệp qua FTP (file transfer protocol) để tạo danh sách thư mục, bao gồm tệp cục bộ và thực thi mã từ xa. Hiện PoC của lỗ hổng đã được công khai.

CVE-2023-4634.png

Người dùng plugin Media-Library-Assistant được khuyến cáo nâng cấp lên phiên bản 3.10. Nếu website chưa được cập nhật tự động, bạn có thể thực hiện các bước như sau:

  1. Cập nhật thủ công: Truy cập bảng điều khiển WordPress và tải xuống bản vá an ninh. Luôn đảm bảo có bản sao lưu trước khi cập.
  2. Giảm thiểu rủi ro: Là một biện pháp tạm thời, củng cố chính sách bảo mật của Imagick bằng cách vô hiệu hóa các tệp nguy hiểm cần chuyển đổi, chẳng hạn như: “MSL, MSVG, MVG, PS, PDF, RSVG, SVG, XPS, VID”. Điều này có thể được thực hiện bằng cách thêm
<policy domain=”coder” rights=”none” pattern=”SVG” />

<policy domain=”coder” rights=”none” pattern=”MSL” />

<policy domain=”coder” rights=”none” pattern=”MSVG” />

<policy domain=”coder” rights=”none” pattern=”MVG” />

<policy domain=”coder” rights=”none” pattern=”VID” />

FROM
/etc/ImageMagick-X/policy.xml

Tính đến thời điểm hiện tại, Wordfence đã chặn 151 cuộc tấn công nhắm vào lỗ hổng này trong 24 giờ qua và chưa có bằng chứng cụ thể nào cho thấy lỗ hổng CVE-2023-4634 bị khai thác trong các cuộc tấn công gần đây.

Đăng ký liền tay Nhận Ngay Bài Mới

Subscribe ngay

Cám ơn bạn đã đăng ký !

Lỗi đăng ký !

Add Comment

Click here to post a comment

Đăng ký liền tay
Nhận Ngay Bài Mới

Subscribe ngay

Cám ơn bạn đã đăng ký !

Lỗi đăng ký !