Tin An Ninh Mạng

Apple vá lỗi KRACK trên thiết bị AirPort Base Station

Tuần trước, Apple đã phát hành bản cập nhật cho firmware của các bộ định tuyến AirPort Base Station để vá các lỗ hổng đặt thiết bị trước nguy cơ bị tấn công KRACK (Key Reinstallation attack – tấn công cài đặt lại mã khóa).

{

}

Airport Express Base Station.JPG

Trước đó vào tháng 10/2017, lỗ hổng KRACK được phát hiện trong chính tiêu chuẩn Wi-Fi. Lỗ hổng khiến tất cả các triển khai giao thức WPA2 đều có nguy cơ bị tấn công. Các thiết bị mạng cũng được phát hiện là không an toàn trước kiểu tấn công mới này.
Ngay sau khi lỗ hổng trên được công bố, các hãng đều chạy đua để cập nhật bản vá. Tùy thuộc vào việc thiết lập giao thức, mỗi sản phẩm có thể bị ảnh hưởng bởi một hoặc nhiều hơn từ 10 vấn đề liên quan đến tấn công KRACK.
Trong đợt cập nhật bản vá cho KRACK đầu tiên vào ngày 31/10, Apple đã xử lý các lỗ hổng sau: CVE-2017-13080 trong iOS, tvOS, và watchOS, và 3 lỗi (CVE-2017-13077, CVE-2017-13078 và CVE-2017-13080) trong macOS High Sierra.
Đầu tháng 12, công ty này cũng phát hành một loạt các bản vá lỗi liên quan đến KRACK để xử lý CVE-2017-13080 trong:

  • Apple Watch thế hệ 1
  • Apple Watch Series 3
  • Apple TV thế hệ thứ 4
  • nhiều thiết bị iOS (iPhone 6s, iPhone 6s Plus, iPhone 6, iPhone 6 Plus, iPhone SE, iPhone 5s, 12.9-inch iPad Pro thế hệ 1, iPad Air 2, iPad Air, iPad thế hệ 5, iPad mini 4, iPad mini 3, iPad mini 2, và iPod touch thế hệ 6).

Lần này, Apple tung ra 2 bản cập nhật an ninh cho firmware của các bộ định tuyến không dây AirPort Base Station.
Với việc phát hành bản cập nhật firmware này, Apple đã xử lý ba lỗ hổng KRACK (CVE-2017-13077, CVE-2017-13078 và CVE-2017-13080) trong AirPort Express, AirPort Extreme và AirPort Time Capsule base station chuẩn 802.11n.
Bản cập nhật firmware 7.7.9 cho AirPort Base Station vá ba lỗi trong bộ định tuyến AirPort Extreme và AirPort Time Capsule chuẩn 802.11ac. Bản cập nhật cũng khắc phục lỗi thứ tư – CVE-2017-9417 – có thể cho phép kẻ tấn công thực thi mã tùy ý trên chip Wi-Fi.
Trong một cảnh báo được công bố vào đầu tuần trước, Đội phản ứng nhanh an ninh mạng máy tính của Mỹ US-CERT đã khuyến cáo người dùng và quản trị viên vào các trang cập nhật firmware của AirPort Base Station 7.6.9 và Firmware Update 7.7.9 để cập nhật các bản vá cần thiết.

Theo Securityweek

Đăng ký liền tay Nhận Ngay Bài Mới

Subscribe ngay

Cám ơn bạn đã đăng ký !

Lỗi đăng ký !

Add Comment

Click here to post a comment

Đăng ký liền tay
Nhận Ngay Bài Mới

Subscribe ngay

Cám ơn bạn đã đăng ký !

Lỗi đăng ký !